FORUM Forums Software CLS2SIM Software vJoy driver suddenly showing as 'Not installed'

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #414

    Today I noticed an issue I haven’t seen before.

    Doing a rather long flight between ESSA-LEMG when I was about 1 hour out from LEMG I realized none of the buttons on my yoke was working anymore. Looking in the CLS2Sim software on the buttons tab I noticed how the vJoy driver all of a sudden showed as ‘Not installed’ even when it certainly is installed and was working just fine also on this flight for the first 3 hours or so.

    I didn’t dare to restart the CLS2Sim software in-flight scared of loosing the complete flight if I couldn’t get the connection between CLS2Sim and P3Dv3 up and running again. Also with the pitch and roll still working I figured I would still be able to land although having to trim, disconnect the A/T etc using the mouse instead. A bit cumbersome when flying in VR but it worked out OK.

    Once on the ground I tried restarting CLS2Sim and it reconnected to P3Dv3 and the NGX just fine and the vJoy status was back to its normal ‘Installed’ status and the buttons were all working perfectly OK again.

    Great to know there’s no problem restarting CLS2Sim should this happen again but would still be nice to know what caused the issue in the first place. Maybe (hopefully) it was just one of those ‘one-time-only’ kind of issues.

    Anyone else seen the same thing?



    If its hapens again please check if you still see the buttons state change in CLS2Sim
    when you press a button.

    Also check if the the 3 buttons on the display still working




    Thanks for the prompt reply Stefan.

    I already did check the button state in CLS2Sim and I can confirm they all worked as normal. The problem was only outside CLS2Sim which I guess makes sense since vJoy no longer showed up as installed and I have all buttons configured for USB use.

    I’m 99% sure the buttons on the display were working as normal.




    Hi Richard

    Better you map buttons like trim or autopilot directly in CLS2Sim, so when vjoy fails for any reason buttons will still work
    Try to in uninstall/install vjoy if happens again




    Since I’ve only see this happen once and I did lots of flying lately I will just leave it for now but will keep your suggestion in mind should I face the same issue again.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.


In the BRUNNER forum you will find various discussions on different topics, such as setup, software use or general questions and concerns. 

Discuss with forum mebers, share your knowledge and experience or find answers to frequently asked questions that are answered directly by our Brunner team.

Go to BRUNNER Forum.

BRUNNER Helpdesk​

Do you have questions about a product you have already purchased or are you facing technical issues? 

Check our FAQs for quick help. The most common questions or problems are described there, including instructions.

If you are still stuck, please contact our BRUNNER Helpdesk. Open a ticket here.

BRUNNER Simulation​

BRUNNER is a leading manufacturer of flight simulation devices for the professional as well as the enthusiast sector.

Unlike other manufacturers, Brunner offers a realistic flight experience with the help of Force Feedback Technology and Control Loading System.

Discover the BRUNNER Shop.

BRUNNER Simulation

Industriestrasse 27
8335 Hittnau

+41 (0)44 953 10 10

© 2023 BRUNNER Elektronik AG | Privacy Policy |  Legal notice